Question about Dual Locs.

Discuss maps, trains and other modding topics
Bushdoctor
Posts: 116
Joined: Sun Dec 17, 2006 12:39 pm
Location: The Netherlands

Post by Bushdoctor » Tue Feb 19, 2008 7:16 am

Agent Doctor reporting in.
I have been quite succesful with a couple of things.

I managed to create an extra dual with the De Glehn.
A full entry for both versions in the rrt_trains_<map>.xml did the trick.

I also managed to edit Year, Maxspeed, Speed0, Power, Cost and Maintenance Cost for all other trains by adding the appropriate tags.

All trains except for the Mikado Dual Loc... and that's strange.
As soon as I add just one single line to the 'default' entry the map crashes
while loading.
As long as it looks like this it's okay:
<szName>TAG_NAME_MIKADO_DUAL</szName>
<szManufacturerName>Lima</szManufacturerName>
<Year>1916</Year>
All other trains allow adding more tags to adjust the above mentioned things,
but not this engine. A single addition to the above list makes it go boom.
It does allow changing its date btw.

Any ideas?
Could the original entry in rrt_trains.xml somehow be wrong for the Dual Mikado?
Is there anything that makes the Mikado different from all other trains?
(Except for its seemingly out of place super power).

Bushdoctor
Posts: 116
Joined: Sun Dec 17, 2006 12:39 pm
Location: The Netherlands

Post by Bushdoctor » Tue Feb 19, 2008 7:40 am

Holy crap.
I think I have solved it.
The Mikado Dual does allow edits, but it needs its full entry in the
rrt_trains_<map>.xml.
It didn't CTD, I'm taking her for a test spin....

Bushdoctor
Posts: 116
Joined: Sun Dec 17, 2006 12:39 pm
Location: The Netherlands

Post by Bushdoctor » Tue Feb 19, 2008 8:50 am

Hmm. I didn't get to test the Mikado Dual yet
because other problems popped up with the De Glehn Dual.

Firstly, the engine does not visually appear as a dual locomotive.
It appears as a regular single loc, but with the power etc of a dual.

Secondly, the Dual Glehn does not want to accept any other car than Passengers.
Which is strange because the prefered cargo for that dual loc reads Mixed.
The single Glehn accepts any car but has Passengers as prefered cargo.

I've got a feeling that these Prefered Cargo designations are being determined
by the speed or power of a train. I haven't found an entry refering to this.

Any idea why my Dual Glehn only wants to accept Passenger cars?
Here's the xml entry:


<Train>
<szName>TAG_NAME_DE_GLEHN_DUAL</szName>
<Year>1911</Year>
<szManufacturerName>De Glehn</szManufacturerName>
<szModel>4_4_2_deGlehnAtlantic.kfm</szModel>
<szDummyModel>4_4_2_deGlehnAtlantic_dummies.nif</szDummyModel>
<szCar>_v1</szCar>
<szNewTrainImage>event_newtrain_4_4_0_deGlehn.dds</szNewTrainImage>
<szGroundClackSound>AS3D_CLACK_PLANET_GROUND</szGroundClackSound>
<szBridgeClackSound>AS3D_CLACK_PLANET_BRIDGE</szBridgeClackSound>
<MaxSpeed>9</MaxSpeed>
<Speed0>9</Speed0>
<Power>16</Power>
<Cost>340000</Cost>
<MaintenanceCost>10000</MaintenanceCost>
<Diesel>0</Diesel>
<RunLength>88</RunLength>
<HasEngineer>1</HasEngineer>
<rgbDefaultColor>230,0,0</rgbDefaultColor>
<fStartSoundCrossFade>2.0</fStartSoundCrossFade>
<fSpeedStartWait>0.25</fSpeedStartWait>
<fSpeedCrossFade>3.0</fSpeedCrossFade>
<iPitchChange>4000</iPitchChange>
<szTenderCar>DeGlehnDummy</szTenderCar>
<BitmapIcon>
<szFile>Assets/Interface/TrainRouting/routing_deGlehnAtlantic.tga</szFile>
</BitmapIcon>
<SpeedSounds>
<szSpeed>AS3D_TR_STEAM_ENGINE_SLOW_LP_1</szSpeed>
<szSpeed>AS3D_TR_STEAM_ENGINE_MID_SLOW_LP_1</szSpeed>
<szSpeed>AS3D_TR_STEAM_ENGINE_MID_FAST_LP_1</szSpeed>
<szSpeed>AS3D_TR_STEAM_ENGINE_FAST_LP_1</szSpeed>
</SpeedSounds>
<szStartSound>AS3D_TR_STEAM_ENGINE_START_4</szStartSound>
<szStopSound>AS3D_TR_STEAM_ENGINE_STOP_4</szStopSound>
<szSharpAngleSqueal>AS3D_CURVE_SQUEAL</szSharpAngleSqueal>
<szAverageAngleSqueal>AS3D_CURVE_SQUEAL_MEDIUM</szAverageAngleSqueal>
<szSlightAngleSqueal>AS3D_CURVE_SQUEAL_LIGHT</szSlightAngleSqueal>
</Train>

The only edit that I made without an example was the <szTenderCar>DeGlehnDummy</szTenderCar> .
Perhaps I chose a wrong name and perhaps this is the cause of only a single engine showing up?

User avatar
Rodea2007
Posts: 482
Joined: Mon Jun 11, 2007 3:58 am
Location: Jakarta, Indonesia
Contact:

Post by Rodea2007 » Tue Feb 19, 2008 9:48 am

Bushdoctor wrote:Hmm. I didn't get to test the Mikado Dual yet
because other problems popped up with the De Glehn Dual.

Firstly, the engine does not visually appear as a dual locomotive.
It appears as a regular single loc, but with the power etc of a dual.

Secondly, the Dual Glehn does not want to accept any other car than Passengers.
Which is strange because the prefered cargo for that dual loc reads Mixed.
The single Glehn accepts any car but has Passengers as prefered cargo.

I've got a feeling that these Prefered Cargo designations are being determined
by the speed or power of a train. I haven't found an entry refering to this.

Any idea why my Dual Glehn only wants to accept Passenger cars?
Here's the xml entry:


<Train>
<szName>TAG_NAME_DE_GLEHN_DUAL</szName>
<Year>1911</Year>
<szManufacturerName>De Glehn</szManufacturerName>
<szModel>4_4_2_deGlehnAtlantic.kfm</szModel>
<szDummyModel>4_4_2_deGlehnAtlantic_dummies.nif</szDummyModel>
<szCar>_v1</szCar>
<szNewTrainImage>event_newtrain_4_4_0_deGlehn.dds</szNewTrainImage>
<szGroundClackSound>AS3D_CLACK_PLANET_GROUND</szGroundClackSound>
<szBridgeClackSound>AS3D_CLACK_PLANET_BRIDGE</szBridgeClackSound>
<MaxSpeed>9</MaxSpeed>
<Speed0>9</Speed0>
<Power>16</Power>
<Cost>340000</Cost>
<MaintenanceCost>10000</MaintenanceCost>
<Diesel>0</Diesel>
<RunLength>88</RunLength>
<HasEngineer>1</HasEngineer>
<rgbDefaultColor>230,0,0</rgbDefaultColor>
<fStartSoundCrossFade>2.0</fStartSoundCrossFade>
<fSpeedStartWait>0.25</fSpeedStartWait>
<fSpeedCrossFade>3.0</fSpeedCrossFade>
<iPitchChange>4000</iPitchChange>
<szTenderCar>DeGlehnDummy</szTenderCar>
<BitmapIcon>
<szFile>Assets/Interface/TrainRouting/routing_deGlehnAtlantic.tga</szFile>
</BitmapIcon>
<SpeedSounds>
<szSpeed>AS3D_TR_STEAM_ENGINE_SLOW_LP_1</szSpeed>
<szSpeed>AS3D_TR_STEAM_ENGINE_MID_SLOW_LP_1</szSpeed>
<szSpeed>AS3D_TR_STEAM_ENGINE_MID_FAST_LP_1</szSpeed>
<szSpeed>AS3D_TR_STEAM_ENGINE_FAST_LP_1</szSpeed>
</SpeedSounds>
<szStartSound>AS3D_TR_STEAM_ENGINE_START_4</szStartSound>
<szStopSound>AS3D_TR_STEAM_ENGINE_STOP_4</szStopSound>
<szSharpAngleSqueal>AS3D_CURVE_SQUEAL</szSharpAngleSqueal>
<szAverageAngleSqueal>AS3D_CURVE_SQUEAL_MEDIUM</szAverageAngleSqueal>
<szSlightAngleSqueal>AS3D_CURVE_SQUEAL_LIGHT</szSlightAngleSqueal>
</Train>

The only edit that I made without an example was the <szTenderCar>DeGlehnDummy</szTenderCar> .
Perhaps I chose a wrong name and perhaps this is the cause of only a single engine showing up?

Try to add line "<PassengersAndMailOnly>0</PassengersAndMailOnly>" below "<Diesel>0</Diesel>"

snoopy55
Posts: 1962
Joined: Mon Nov 06, 2006 5:13 am
Location: Centralia, Ill, USA

Post by snoopy55 » Tue Feb 19, 2008 10:12 pm

I'll go anlong with Rodea2007 as a possible solution. That is one of the lines that Firaxes put in some and left out of others, here only putting it in where it was needed.

As to the DeGlehn Dummy, there is none in my RRT_TrainCars.xml which is where the Tenders are. You would have to build one or have one built. This is why you don't see the second engine. This could also be why it wont accept anything but Passengers. The 'Why' part I wouldn't know, but the possibility is there. As to having the power and such of a Dual, you made those settings, so even if you set the second unit as a go-cart, it would still have the power. The second unit is just for looks, no more. But you need to get it into your RRT_TrainCars_<map>.xml.
I'm correct 97% of the time..... who cares about the other 4%....

User avatar
Rodea2007
Posts: 482
Joined: Mon Jun 11, 2007 3:58 am
Location: Jakarta, Indonesia
Contact:

Post by Rodea2007 » Wed Feb 20, 2008 3:38 am

Bushdoctor wrote:Hmm. I didn't get to test the Mikado Dual yet
because other problems popped up with the De Glehn Dual.

Firstly, the engine does not visually appear as a dual locomotive.
It appears as a regular single loc, but with the power etc of a dual.

Secondly, the Dual Glehn does not want to accept any other car than Passengers.
Which is strange because the prefered cargo for that dual loc reads Mixed.
The single Glehn accepts any car but has Passengers as prefered cargo.

I've got a feeling that these Prefered Cargo designations are being determined
by the speed or power of a train. I haven't found an entry refering to this.

Any idea why my Dual Glehn only wants to accept Passenger cars?
Here's the xml entry:


<Train>
<szName>TAG_NAME_DE_GLEHN_DUAL</szName>
<Year>1911</Year>
<szManufacturerName>De Glehn</szManufacturerName>
<szModel>4_4_2_deGlehnAtlantic.kfm</szModel>
<szDummyModel>4_4_2_deGlehnAtlantic_dummies.nif</szDummyModel>
<szCar>_v1</szCar>
<szNewTrainImage>event_newtrain_4_4_0_deGlehn.dds</szNewTrainImage>
<szGroundClackSound>AS3D_CLACK_PLANET_GROUND</szGroundClackSound>
<szBridgeClackSound>AS3D_CLACK_PLANET_BRIDGE</szBridgeClackSound>
<MaxSpeed>9</MaxSpeed>
<Speed0>9</Speed0>
<Power>16</Power>
<Cost>340000</Cost>
<MaintenanceCost>10000</MaintenanceCost>
<Diesel>0</Diesel>
<RunLength>88</RunLength>
<HasEngineer>1</HasEngineer>
<rgbDefaultColor>230,0,0</rgbDefaultColor>
<fStartSoundCrossFade>2.0</fStartSoundCrossFade>
<fSpeedStartWait>0.25</fSpeedStartWait>
<fSpeedCrossFade>3.0</fSpeedCrossFade>
<iPitchChange>4000</iPitchChange>
<szTenderCar>DeGlehnDummy</szTenderCar>
<BitmapIcon>
<szFile>Assets/Interface/TrainRouting/routing_deGlehnAtlantic.tga</szFile>
</BitmapIcon>
<SpeedSounds>
<szSpeed>AS3D_TR_STEAM_ENGINE_SLOW_LP_1</szSpeed>
<szSpeed>AS3D_TR_STEAM_ENGINE_MID_SLOW_LP_1</szSpeed>
<szSpeed>AS3D_TR_STEAM_ENGINE_MID_FAST_LP_1</szSpeed>
<szSpeed>AS3D_TR_STEAM_ENGINE_FAST_LP_1</szSpeed>
</SpeedSounds>
<szStartSound>AS3D_TR_STEAM_ENGINE_START_4</szStartSound>
<szStopSound>AS3D_TR_STEAM_ENGINE_STOP_4</szStopSound>
<szSharpAngleSqueal>AS3D_CURVE_SQUEAL</szSharpAngleSqueal>
<szAverageAngleSqueal>AS3D_CURVE_SQUEAL_MEDIUM</szAverageAngleSqueal>
<szSlightAngleSqueal>AS3D_CURVE_SQUEAL_LIGHT</szSlightAngleSqueal>
</Train>

The only edit that I made without an example was the <szTenderCar>DeGlehnDummy</szTenderCar> .
Perhaps I chose a wrong name and perhaps this is the cause of only a single engine showing up?
This is solution for your trouble Guy's.....

only a few steps... :wink:

Put this entry below in your Global Files

1. RRT_Names_ENU.xml

<TextKey>
<Tag>TAG_NAME_MIKADO_DUAL</Tag>
<Text>Mikado Dual</Text>
<Gender>M</Gender>
</TextKey>

<TextKey>
<Tag>TAG_NAME_DE_GLEHN_DUAL</Tag>
<Text>De Glehn Dual</Text>
<Gender>M</Gender>
</TextKey>

2. RRT_Trains.xml

<Train>
<szName>TAG_NAME_MIKADO_DUAL</szName>
<Year>1911</Year>
<szManufacturerName>Lima</szManufacturerName>
<szModel>2_8_2_Mikado.kfm</szModel>
<szDummyModel>2_8_2_Mikado_dummies.nif</szDummyModel>
<szCar>_v2</szCar>
<szNewTrainImage>event_newtrain_2_8_2_Mikado.dds</szNewTrainImage>
<szGroundClackSound>AS3D_CLACK_PLANET_GROUND</szGroundClackSound>
<szBridgeClackSound>AS3D_CLACK_PLANET_BRIDGE</szBridgeClackSound>
<MaxSpeed>6</MaxSpeed>
<Speed0>6</Speed0>
<Power>40</Power>
<Cost>180000</Cost>
<MaintenanceCost>7800</MaintenanceCost>
<Diesel>0</Diesel>
<RunLength>162</RunLength>
<HasEngineer>1</HasEngineer>
<rgbDefaultColor>200,150,0</rgbDefaultColor>
<fStartSoundCrossFade>2.0</fStartSoundCrossFade>
<fSpeedStartWait>0.25</fSpeedStartWait>
<fSpeedCrossFade>3.0</fSpeedCrossFade>
<iPitchChange>4000</iPitchChange>
<szTenderCar>MikadoDummy</szTenderCar>
<BitmapIcon>
<szFile>routing_Mikado.tga</szFile>
</BitmapIcon>
<SpeedSounds>
<szSpeed>AS3D_TR_STEAM_ENGINE_SLOW_LP_1</szSpeed>
<szSpeed>AS3D_TR_STEAM_ENGINE_MID_SLOW_LP_1</szSpeed>
<szSpeed>AS3D_TR_STEAM_ENGINE_MID_FAST_LP_1</szSpeed>
<szSpeed>AS3D_TR_STEAM_ENGINE_FAST_LP_1</szSpeed>
</SpeedSounds>
<szStartSound>AS3D_TR_STEAM_ENGINE_START_1</szStartSound>
<szStopSound>AS3D_TR_STEAM_ENGINE_STOP_1</szStopSound>
<szSharpAngleSound>AS3D_CURVE_SQUEAL</szSharpAngleSound>
<szAverageAngleSound>AS3D_CURVE_SQUEAL_MEDIUM</szAverageAngleSound>
<szSlightAngleSound>AS3D_CURVE_SQUEAL_LIGHT</szSlightAngleSound>
</Train>

<Train>
<szName>TAG_NAME_DE_GLEHN_DUAL</szName>
<Year>1910</Year>
<szManufacturerName>De Glehn</szManufacturerName>
<szModel>4_4_2_deGlehnAtlantic.kfm</szModel>
<szDummyModel>4_4_2_deGlehnAtlantic_dummies.nif</szDummyModel>
<szCar>_v2</szCar>
<szNewTrainImage>event_newtrain_4_4_0_deGlehn.dds</szNewTrainImage>
<szGroundClackSound>AS3D_CLACK_PLANET_GROUND</szGroundClackSound>
<szBridgeClackSound>AS3D_CLACK_PLANET_BRIDGE</szBridgeClackSound>
<MaxSpeed>8</MaxSpeed>
<Speed0>8</Speed0>
<Power>8</Power>
<Cost>80000</Cost>
<MaintenanceCost>3500</MaintenanceCost>
<Diesel>0</Diesel>
<RunLength>88</RunLength>
<HasEngineer>1</HasEngineer>
<rgbDefaultColor>230,0,0</rgbDefaultColor>
<BitmapIcon>
<szFile>Assets/Interface/TrainRouting/routing_deGlehnAtlantic.tga</szFile>
</BitmapIcon>
<fStartSoundCrossFade>2.0</fStartSoundCrossFade>
<szStartSound>AS3D_TR_STEAM_ENGINE_START_4</szStartSound>
<szStopSound>AS3D_TR_STEAM_ENGINE_STOP_4</szStopSound>
<fSpeedStartWait>0.25</fSpeedStartWait>
<fSpeedCrossFade>3.0</fSpeedCrossFade>
<iPitchChange>4000</iPitchChange>
<SpeedSounds>
<szSpeed>AS3D_TR_STEAM_ENGINE_SLOW_LP_1</szSpeed>
<szSpeed>AS3D_TR_STEAM_ENGINE_MID_SLOW_LP_1</szSpeed>
<szSpeed>AS3D_TR_STEAM_ENGINE_MID_FAST_LP_1</szSpeed>
<szSpeed>AS3D_TR_STEAM_ENGINE_FAST_LP_1</szSpeed>
</SpeedSounds>
<szSharpAngleSqueal>AS3D_CURVE_SQUEAL</szSharpAngleSqueal>
<szAverageAngleSqueal>AS3D_CURVE_SQUEAL_MEDIUM</szAverageAngleSqueal>
<szSlightAngleSqueal>AS3D_CURVE_SQUEAL_LIGHT</szSlightAngleSqueal>
<szTenderCar>DE_GLEHNDummy</szTenderCar>
</Train>

3. RRT_TrainCars.xml

<TenderCar>
<szName>MikadoDummy</szName>
<szModel>2_8_2_Mikado.kfm</szModel>
<szDummyModel>2_8_2_Mikado_dummies.nif</szDummyModel>
<szGroundClackSound>AS3D_CLACK_PLANET_GROUND</szGroundClackSound>
<szBridgeClackSound>AS3D_CLACK_PLANET_BRIDGE</szBridgeClackSound>
<RunLength>126</RunLength>
</TenderCar>

<TenderCar>
<szName>DE_GLEHNDummy</szName>
<szModel>4_4_2_deGlehnAtlantic.kfm</szModel>
<szDummyModel>4_4_2_deGlehnAtlantic_dummies.nif</szDummyModel>
<szGroundClackSound>AS3D_CLACK_PLANET_GROUND</szGroundClackSound>
<szBridgeClackSound>AS3D_CLACK_PLANET_BRIDGE</szBridgeClackSound>
<RunLength>88</RunLength>
</TenderCar>


Put this entry in your scenario Map

1. RRT_Trains_yourscenariomap.xml

<Train>
<szName>TAG_NAME_MIKADO_DUAL</szName>
</Train>

<Train>
<szName>TAG_NAME_DE_GLEHN_DUAL</szName>
</Train>

2. RRT_TrainCars_yourscenariomap.xml

<TenderCar>
<szName>MikadoDummy</szName>
</TenderCar>

<TenderCar>
<szName>DE_GLEHNDummy</szName>
</TenderCar>

parameters in De Glehn is original from single De Glehn, you can edit parameters (such as speed, power, cost as whatever do you want.

Suggestion for all peoples..to make a new xml files you must to know about xml and all components supported it
Attachments
Mikado Dual and De Glehn Dual
Mikado Dual and De Glehn Dual
SMRailroads!0002.PNG (1.14 MiB) Viewed 20110 times
De Glehn Dual Loading Limestone
De Glehn Dual Loading Limestone
SMRailroads!0007.png (1.37 MiB) Viewed 20114 times
Mikado Dual loading Limestone
Mikado Dual loading Limestone
SMRailroads!0008.png (1.46 MiB) Viewed 20114 times

Bushdoctor
Posts: 116
Joined: Sun Dec 17, 2006 12:39 pm
Location: The Netherlands

Post by Bushdoctor » Wed Feb 20, 2008 6:15 am

That's a lot more complicated than I expected,
but it works like a charm. Thanks a lot Rodea!

I changed a few small things to match the existing files.
For example I kept all Dual locs v1. I have no idea what the v-numbers do though.

Gotta do a bit more experimenting now. 8)

User avatar
Rodea2007
Posts: 482
Joined: Mon Jun 11, 2007 3:58 am
Location: Jakarta, Indonesia
Contact:

Post by Rodea2007 » Wed Feb 20, 2008 8:19 am

Bushdoctor wrote:That's a lot more complicated than I expected,
but it works like a charm. Thanks a lot Rodea!

I changed a few small things to match the existing files.
For example I kept all Dual locs v1. I have no idea what the v-numbers do though.

Gotta do a bit more experimenting now. 8)
I have a little explanation about "v"

"v" it does meaning Variation

RRT to have 2 Variations

-Variation 1 (v1)
Train with Variation 1 (v1) it does meaning Trains with years under 1900
for example Mogul, American etc. and used carload/TrainCar with variation 1


-Variation 2 (v2)
Train with variation 2 (v2) it does meaning Trains with years above 1900
for example Golden State, F-Series, GP-Series etc, and to use carload/Traincar with v2.

if you make Trains variation is _v1 it does meaning this Trains will be always use Traincar variation 1 not depend year.

Bushdoctor
Posts: 116
Joined: Sun Dec 17, 2006 12:39 pm
Location: The Netherlands

Post by Bushdoctor » Wed Feb 20, 2008 8:37 am

Actually, I knew that. Snoopy explained that to me.
Somehow I was being dumb about it and didn't apply that knowledge
to the duals. - Thanks for the re-explanation! ;)

User avatar
karsten
Posts: 643
Joined: Sun Dec 17, 2006 8:49 pm

Post by karsten » Wed Feb 20, 2008 8:46 pm

Hi Rodea!
What is that interesting-looking map you have there? Can we play it? :P

User avatar
Rodea2007
Posts: 482
Joined: Mon Jun 11, 2007 3:58 am
Location: Jakarta, Indonesia
Contact:

Post by Rodea2007 » Thu Feb 21, 2008 5:18 am

karsten wrote:Hi Rodea!
What is that interesting-looking map you have there? Can we play it? :P
Be pleasure..., but my map not finish yet, because I want to in my map have little different from original map RRT. I want to make a little change
such as cornmeal having fields, decoration(animals) can be animation, add palm as cluter not as decoration etc, I'm in middle working, after finish I will post them as soon as

User avatar
karsten
Posts: 643
Joined: Sun Dec 17, 2006 8:49 pm

Post by karsten » Thu Feb 21, 2008 6:27 am

add palm as cluter
:shock: Well, certainly looking forward if you can get that to work! :P

User avatar
Lowell
Posts: 653
Joined: Sat Mar 24, 2007 2:14 am
Location: Georgia
Contact:

Post by Lowell » Thu Feb 21, 2008 10:38 am

That's what I was saying about making a full listing when you make a new train...or...even a new slave unit. You also needed to make a new train car for the tender like Rodea2007 had showed. There are only a couple things you can change without having to make a full listing like I had mentioned.

I would also like to see if you can get the palm trees in as clutter. I have tried and need to go back and look deeper into it.

I also had mentioned that the car versions are what the <_v1> and <_v2> and even <_tgv> and let's not forget <_bnsf> car types. And...you can create a whole new car type as long as you provide a complete set for what you are building. Like my <_mudtgv> TGV train and car set.

<_v1> pulls only early version one type cars (these cars have a smaller car scale than the v2 cars)...and so on.

Bushdoctor
Posts: 116
Joined: Sun Dec 17, 2006 12:39 pm
Location: The Netherlands

Post by Bushdoctor » Thu Feb 21, 2008 4:01 pm

The thing is, you guys are all so technically experienced with this game
that sometimes simple stuff sounds hard when you explain it. ;)

If i'm correct we can boil it down to: After 1900, v1 trains keep using old cars
and v2 trains start using new cars.

The fact that all existing Dual engines are v1 (which is pretty strange) kind
of threw me off.

Lowell, you did indeed mention all of that but it was a bit hard for me to
get a grasp on all involved components. Sometimes an example works
best for me. It allows me to copy and learn without going nuts over too many
failed experiments. I think I must have started the game over 20 times in
order to test the dual locs and in hindsight I wasn't even close because I was
missing several entries in global files. You might have mentioned those
but it probably didn't sink in. Sorry.

Well, it's running marvelously now. I just have to fine tune the victory conditions a bit more.
Thanks a lot for all your help folks! It's very much appreciated.

normandlandry
Posts: 8
Joined: Fri Mar 11, 2011 5:46 pm

Re: Question about Dual Locs.

Post by normandlandry » Thu Mar 24, 2011 4:50 pm

@Lowell: Mr Lowell, I have been looking for one of your posts so I may ask you directly: I like your maps very much! Playing yours saves me time looking for the things I'd like to see in Railroads! I play many maps searching for the rewards that your maps seem to all contain! To save me a great deal of searching and a whole lot of unnecessary reading, could you point me to a location that has all of your available maps? I am unable to register a Bobby's and I've played all the maps at Simple. I like to see many types of trains and duals, lots of them. I like annexes that accept things like fertilizer, passengers, workers etc. Your maps have the kinds of things that Railroads! is missing. Q: Is it possible for you to place resources at a station with four tracks instead of an annex with only three? The alternating fashion that annexes use to load trains is confounding efficiency. I'm pushing all envelopes with regard to a stations ability to receive and send items. I believe your maps and skills can help me push even further. Thank you.

Post Reply