Missing Audio Files

It's not a map? It's not a Train? Share and download the files here
Post Reply
Tijer
Posts: 80
Joined: Wed Dec 20, 2006 6:10 am
Location: Magic City, Banana Republic, Florida

Missing Audio Files

Post by Tijer » Wed Jan 23, 2008 4:51 am

While doing some XML repairs I discovered 4 files that where listed in the Audiodefines.XML but not on my system. Now since nobody to my knowledge has ever messed with the audio files, I suggest that people check to see if these files exist on their system. The file names are:

smallclink
buyoutgood
buyoutbad
AngelBand

The one called smallclink came up as I was reviewing the logs after a crash. As of yet I do not know if these files are essential or just sound effect that can be ignored. Since the one mentioned above actually came up as an error, I am planning on placing another file with a similar name in its place. If you have the files please upload them to this thread. Thanks
Intel Core 2 Quad Q6600@2.4GHz
2 GB PC5400 DDR2 Ram
MB nVidia nForce 680i LT SLI
GC GeForce 7300GS 256MB PCI-E
HD 250GB + 500GB
OS Windows XP/SP2/32 bit

Bushdoctor
Posts: 116
Joined: Sun Dec 17, 2006 12:39 pm
Location: The Netherlands

Post by Bushdoctor » Wed Jan 23, 2008 11:23 am

They don't appear to be on my system.

I have done a bit of messing around with audio files.
Files with the same name will be picked up by the game.
The game makes no difference between wav and mp3.

Not a lot of info, but it seems that your plan should work.
Good luck!

Tijer
Posts: 80
Joined: Wed Dec 20, 2006 6:10 am
Location: Magic City, Banana Republic, Florida

Post by Tijer » Wed Jan 23, 2008 12:40 pm

I also notice that it does not matter about the version number at the end either. But something has to be there.
Intel Core 2 Quad Q6600@2.4GHz
2 GB PC5400 DDR2 Ram
MB nVidia nForce 680i LT SLI
GC GeForce 7300GS 256MB PCI-E
HD 250GB + 500GB
OS Windows XP/SP2/32 bit

User avatar
Lowell
Posts: 653
Joined: Sat Mar 24, 2007 2:14 am
Location: Georgia
Contact:

Post by Lowell » Wed Jan 23, 2008 3:05 pm

I've replaced my in-game music with regular music...it works great too. For the Christmas maps I have a special set of music as well. The sounds you speak of are not in the game, I've looked for them before. The errors have always been there from day one.

It is likely that they at the last moment used a different sound, leaving the old text entry, so adding a sound may give you two.

Those can be replaced with new sounds The audio files are not hard, there is two of them and they are huge lists...I've read through them several times as I am about to add sound effects for some industries and city music. Industry sound effects are cool...I'm about to add some. You can also "group" sounds so they go off as a sound set. Like what happens with the fishery...there are about four sounds that go off to make the waves, seagulls etc.

Most likely...the missing sound files did not cause your crash. I have had several sound folders wirth of stuff removed and still listed globaly...all you get is quiet...and a log full.

Tijer
Posts: 80
Joined: Wed Dec 20, 2006 6:10 am
Location: Magic City, Banana Republic, Florida

Post by Tijer » Wed Jan 23, 2008 9:44 pm

This file has been mentioned before and the fact that is not a ambient music file may make the difference. This file is the direct result of closing a message. Which ties into Bushdoctor's complaint about a crash occurring at a random event. The error is not a crash as in a CTD but a freeze. I believe that the game freeze occurs because missing file and something else happen in concurrency. In another words, the problem becomes compounded, and does not effect all machines. But this game can not get past this event without the freeze. By the way the event is trying to tell me mission complete. When I close the message the game freezes. Sorry for the madness but I do have a method to it. Thanks.
Intel Core 2 Quad Q6600@2.4GHz
2 GB PC5400 DDR2 Ram
MB nVidia nForce 680i LT SLI
GC GeForce 7300GS 256MB PCI-E
HD 250GB + 500GB
OS Windows XP/SP2/32 bit

User avatar
CalmDragon
Posts: 137
Joined: Thu Jun 07, 2007 7:08 pm
Location: Los Angeles, California
Contact:

Post by CalmDragon » Thu Jan 24, 2008 4:47 am

They are missing for me too. And the un-ability to find them has been the last line of audio log after a CTD for me on a map that I created.
motherboard : Asus P5N-E SLI
processor: Dual Core 2.4 GHz
memory : 2046MB
video card: GeForce 8800GTS 640MB
operating system: winxp media
Display: 24" Dell at 1920x1200

User avatar
Lowell
Posts: 653
Joined: Sat Mar 24, 2007 2:14 am
Location: Georgia
Contact:

Post by Lowell » Thu Jan 24, 2008 7:36 am

let's just take a key click out of windows...make a few more to replace the others. Even a quick burst of quiet saved to a sound file will work. Then see what happens.

Tijer
Posts: 80
Joined: Wed Dec 20, 2006 6:10 am
Location: Magic City, Banana Republic, Florida

Post by Tijer » Thu Jan 24, 2008 3:19 pm

The attached zip contains the music that is missing install it to the same location as the first. This is only an experiment.
Attachments
Angelband.zip
(1.24 KiB) Downloaded 527 times
Intel Core 2 Quad Q6600@2.4GHz
2 GB PC5400 DDR2 Ram
MB nVidia nForce 680i LT SLI
GC GeForce 7300GS 256MB PCI-E
HD 250GB + 500GB
OS Windows XP/SP2/32 bit

Post Reply