BC Interior BETA

Develop, collaborate, test and share new maps
User avatar
CeeBee51
Posts: 141
Joined: Sun Dec 17, 2006 9:58 pm
Location: Chase BC Canada
Contact:

BC Interior BETA

Post by CeeBee51 » Sat Jan 06, 2007 2:56 pm

Map Name : BC Interior
Map Size : 225x225
Scenerio : yes(beta)
Multiplayer : not tested as such
Version : BETA 0.9
Date : JAN 6/07

Please post or pm me if you have problems or suggestions. The map and scenerio are a work in progress but I've had fun playing so far.
Chuck " CeeBee" Barkman

Here is revised SAM version of the game. Nothing was changed, only a generic Events file was added.
BC_GOLD_SAM_R.7z
Rev.Events. Sept.6,2010
(2.57 MiB) Downloaded 579 times
Jancsika
Attachments
BC_Gold_SAM.zip
(4.05 MiB) Downloaded 592 times
BC_GOLD.jpg
BC_GOLD.jpg (24.85 KiB) Viewed 12008 times
BC Interior.rar
(709.03 KiB) Downloaded 891 times

User avatar
atani
Posts: 293
Joined: Tue Dec 19, 2006 5:01 pm
Contact:

Re: BC Interior BETA

Post by atani » Sat Jan 06, 2007 7:00 pm

CeeBee51 wrote:Map Name : BC Interior
Map Size : 225x225
Scenerio : yes(beta)
Multiplayer : not tested as such
Version : BETA 0.9
Date : JAN 6/07

Please post or pm me if you have problems or suggestions. The map and scenerio are a work in progress but I've had fun playing so far.
Chuck " CeeBee" Barkman
Unfortunately this crashes on load just before it finishes loading and enters the game :(

I tried with and without AIs. I even tried renaming to remove the space in the name (including the scenario xml) with no luck. Even the terrain editor crashes on load :(

Mike

User avatar
dwax
Posts: 618
Joined: Sat Nov 18, 2006 3:40 pm
Location: So. Dak.

Post by dwax » Sat Jan 06, 2007 7:10 pm

Working good so far for me :lol: I did a little modfi, I started with 999 milion dollars so I can buy out the AI fast if it get's any ideas. :lol:

snoopy55
Posts: 1961
Joined: Mon Nov 06, 2006 5:13 am
Location: Centralia, Ill, USA

Post by snoopy55 » Sat Jan 06, 2007 7:47 pm

Mine drops out just like atanis. As it is working for dwax, what downloads and Mods do you have loaded into your game CeeBee? I have the following:

Ver 1.100

Under CustomAssets -

Bunit2.FPK
Bunit.FPK
GP7.FPK
NewTenders.FPK
RRT_TrainCars.xml (which added tenders to train cars)

Under _SCENARIOS_

RRT_Goods.xml
RRT_Patents.xml
RRT_TrainCars.xml
RRT_Train.xml

atanis and dwax, what you do have and not have of that list and what else not listed :?:
I'm correct 97% of the time..... who cares about the other 4%....

User avatar
atani
Posts: 293
Joined: Tue Dec 19, 2006 5:01 pm
Contact:

Post by atani » Sat Jan 06, 2007 8:22 pm

attached is a find output for the CustomAssets tree. I dont have the BC Interior mod in this tree right now.
Attachments
assets.txt
(17.56 KiB) Downloaded 1287 times

Pete
Posts: 97
Joined: Fri Nov 03, 2006 7:06 pm
Location: British Columbia

Post by Pete » Sat Jan 06, 2007 8:47 pm

It starts fine for me, but every time the clock hits November, 1938
It crashes to desktop. Always Nov 1938. Loaded 5 times; 5 crashes on same date.

I don't know anything about xml.......but the file "RRT_depots_BC interior.xml" wont open for me. I get an error message.
Could this have anything to do with it?

Love the map.......worked fine up to that date.

Pete

User avatar
atani
Posts: 293
Joined: Tue Dec 19, 2006 5:01 pm
Contact:

Post by atani » Sat Jan 06, 2007 9:04 pm

Pete wrote:It starts fine for me, but every time the clock hits November, 1938
It crashes to desktop. Always Nov 1938. Loaded 5 times; 5 crashes on same date.

I don't know anything about xml.......but the file "RRT_depots_BC interior.xml" wont open for me. I get an error message.
Could this have anything to do with it?

Love the map.......worked fine up to that date.

Pete
Open the file with notepad and then go to the bottom and look for "Ore Mine Annex", the "Depot" line is missing the opening <

Mike

User avatar
dwax
Posts: 618
Joined: Sat Nov 18, 2006 3:40 pm
Location: So. Dak.

Post by dwax » Sat Jan 06, 2007 9:10 pm

snoopy55

I have just about the same as you. I don't know why it works for me. The only thing I did was run a money trainer when I opened it.Then saved the game closed the trainer and played the saved game.

User avatar
d53642
Posts: 171
Joined: Thu Oct 26, 2006 7:27 pm
Location: Halifax NS

Post by d53642 » Sat Jan 06, 2007 9:13 pm

The Ore Mine Depot has problems as well, The game actually doesn;t even use it, I have the Ore Mines set to use the Coal mine ones. I screwed up the Animations for the Ore Mine ones and Never bothered fixing them yet.

Daryl

User avatar
CeeBee51
Posts: 141
Joined: Sun Dec 17, 2006 9:58 pm
Location: Chase BC Canada
Contact:

Post by CeeBee51 » Sat Jan 06, 2007 9:13 pm

At the time of zipping it up I had had the following sub-folders in the custom assets folder
Cities (from the santa map)
Industries (Santa map)
Interface (Santa map)
Iron (middle east map)
Metal Factory (middle east map)
Ore Car (middle east map)
Sounds (santa map)
Trains (xmas 4-8-4 plus a few skins)
XML
and in the xml folder I have
Goods.xml
Traincars.xml
Trains.xml
Last edited by CeeBee51 on Sat Jan 06, 2007 9:29 pm, edited 1 time in total.

User avatar
CeeBee51
Posts: 141
Joined: Sun Dec 17, 2006 9:58 pm
Location: Chase BC Canada
Contact:

Post by CeeBee51 » Sat Jan 06, 2007 9:14 pm

atani wrote:
Pete wrote:It starts fine for me, but every time the clock hits November, 1938
It crashes to desktop. Always Nov 1938. Loaded 5 times; 5 crashes on same date.

I don't know anything about xml.......but the file "RRT_depots_BC interior.xml" wont open for me. I get an error message.
Could this have anything to do with it?

Love the map.......worked fine up to that date.

Pete
Open the file with notepad and then go to the bottom and look for "Ore Mine Annex", the "Depot" line is missing the opening <

Mike
Thanks for picking that up, Mike. Maybe thats why iron ore never worked

edit: If there are too many problems I'll go back to the beginning and use only in game assets with no modifiers. I think I can do that without blowing the whole thing up.

Pete
Posts: 97
Joined: Fri Nov 03, 2006 7:06 pm
Location: British Columbia

Post by Pete » Sat Jan 06, 2007 10:06 pm

I made the fix in the xml.........thanks.

Loaded up a new game and it ran about 10 minutes and crashed.

It appears we have 2 threads going. One in talk and one in maps.
Might be easier to bring it into the map side, now we have one going.

Ceebee......minor detail.......I think the town you call Sparwood on your map, should be Greenwood.

Sorry I have no technical expertise, but I'll play with the betas.
Keep at it.........this one's too good to lose.

Pete

User avatar
dwax
Posts: 618
Joined: Sat Nov 18, 2006 3:40 pm
Location: So. Dak.

Post by dwax » Sat Jan 06, 2007 10:24 pm

Found these wonder if they are cause the crash?
Attachments
BC_int.JPG
BC_int.JPG (168.76 KiB) Viewed 13134 times

User avatar
CeeBee51
Posts: 141
Joined: Sun Dec 17, 2006 9:58 pm
Location: Chase BC Canada
Contact:

Post by CeeBee51 » Sat Jan 06, 2007 10:37 pm

dwax.... looks like aliens have landed. ;)
seriously, not sure what that would be from but it's probably something I've got in the assets folder that you don't. The metal factory appears in cities and I think everything else I used is in game stuff so I'm kinda stumped at the moment. :(

snoopy55
Posts: 1961
Joined: Mon Nov 06, 2006 5:13 am
Location: Centralia, Ill, USA

Post by snoopy55 » Sun Jan 07, 2007 12:22 am

atani - I opened that up and while I can decipher some of it, a list done by you would help better.

Pete - what files do you have in Custom_Assets and XML

dwax - just about the same? What's different? Also, those could be the Iron Ore Mines, which shows you don't have the icon for it available.

CeeBee - I ran the files thru an XML program so I can read them easier. I'll look into them tonight. I can remove the Iron Ore Mine related parts and try to run it. I'll play with my copy awhile and see what I can find.
I'm correct 97% of the time..... who cares about the other 4%....

Post Reply